Avaliação do Usuário

Estrela inativaEstrela inativaEstrela inativaEstrela inativaEstrela inativa
 

Pessoal, uma dica rápida, quase não ando tendo tempo.

A versão Electrum 3.0.5 veio acompanhada de um importante "security update" que reparou vulnerabilidades principalmente de carteiras antigas geradas em versões anteriores do software que não estavam criptografadas com senha.

A versão Electrum 3.0.5 foi a última versão que consegui instalar no meu Linux Mint 18.3.

As novas versões lançadas, que neste momento está na versão 3.1.2, apesar de instalar todas as dependências relacionadas ao python 3.4 (ou superior) e ao python-qt5, não estavam rodando no meu sistema operacional.

Dava erro de instalação ao rodar no terminal o código:

sudo pip3 install https://download.electrum.org/3.1.2/Electrum-3.1.2.tar.gz

Resolvi o problema no meu Linux Mint 18.3 (Creio que no Ubuntu também funcione) rodando o seguinte código:

sudo python3 -m pip install https://download.electrum.org/3.1.2/Electrum-3.1.2.tar.gz

Como sei o básico do básico de Python, acredito que ao rodar o segundo comando, o usuário força o terminal a instalar o programa usando a versão superior do python3.

Se alguém souber mais detalhes técnicos sobre esse tipo de erro, deixe um comentário.

Esta solução foi encontrada no próprio Github do Electrum:
https://github.com/spesmilo/electrum/issues/3900

Espero ter ajudado (porque quebrei a cabeça com esse erro básico).

Grande Abraço, Wendel.